synopsys arc architecture · Supported
Maintainers
- M Vineet Gupta <vgupta@kernel.org>
Paths
- F
Documentation/arch/arc - F
Documentation/devicetree/bindings/arc/* - F
Documentation/devicetree/bindings/interrupt-controller/snps,arc* - F
arch/arc/ - F
drivers/clocksource/arc_timer.c - F
drivers/tty/serial/arc_uart.c
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linuxppc-dev (capped at 30), ordered by date desc.
-
STALE72d
[RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
STALE72d
[RFC PATCH v1 2/9] uaccess: Convert INLINE_COPY_{TO/FROM}_USER to kconfig and reduce ifdefery
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
DORMANTno replies
[PATCH v2] cmpxchg: allow const-qualified old value in cmpxchg()
2026-04-03 · Hangbin Liu <hidden> -
STALE99d
[PATCH] cmpxchg: allow const-qualified old value in cmpxchg()
2026-04-02 · Hangbin Liu <hidden> -
STALE105d
REVIEWED: 9 (9M) [PATCH v4 17/25] mm: convert do_brk_flags() to use vma_flags_t
2026-03-20 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
STALE111d
[PATCH v3 17/23] mm: convert do_brk_flags() to use vma_flags_t
2026-03-18 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
STALE112d
[PATCH v2 17/23] mm: convert do_brk_flags() to use vma_flags_t
2026-03-16 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
STALE119d
[PATCH 13/20] mm: convert do_brk_flags() to use vma_flags_t
2026-03-12 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
COLD37d
[PATCH 02/14] arc: axs10x: drop unneeded dependency on OF_GPIO
2026-03-04 · Bartosz Golaszewski <hidden> -
STALE127d
[PATCH] kbuild: Split .modinfo out from ELF_DETAILS
2026-02-25 · Nathan Chancellor <nathan@kernel.org> -
STALE71d
REVIEWED: 12 (12M) [PATCH v3 3/4] arch, mm: consolidate empty_zero_page
2026-02-11 · Mike Rapoport <rppt@kernel.org> -
STALE136d
REVIEWED: 5 (5M) [PATCH v2 3/4] arch, mm: consolidate empty_zero_page
2026-02-09 · Mike Rapoport <rppt@kernel.org> -
STALE151d
[PATCH mm-unstable] arch, mm: consolidate empty_zero_page
2026-01-24 · Mike Rapoport <rppt@kernel.org> -
STALE122d
[PATCH v3 23/29] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE122d
REVIEWED: 1 (1M) [PATCH v3 02/29] arc: introduce arch_zone_limits_init()
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE140d
[PATCH v2 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE140d
[PATCH v2 02/28] arc: introduce arch_zone_limits_init()
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE188d
[PATCH 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE188d
[PATCH 02/28] arc: introduce arch_zone_limits_init()
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE273d
[PATCH RESEND 56/62] init: rename CONFIG_RD_GZIP to CONFIG_INITRAMFS_DECOMPRESS_GZIP
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE273d
[PATCH RESEND 25/62] init: rename phys_initrd_{start,size} to phys_external_initramfs_{start,size}
2025-09-13 · Askar Safin <hidden> -
STALE294d
LANDED [PATCH v2 3/4] arch: copy_thread: pass clone_flags as u64
2025-09-01 · Simon Schuster via B4 Relay <devnull+schuster.simon.siemens-energy.com@kernel.org> -
STALE265d
[PATCH] defconfig: cleanup orphaned CONFIG_SCHED_DEBUG
2025-08-28 · Trevor Woerner <hidden> -
STALE316d
[PATCH 17/19] perf: Retire PERF_PMU_CAP_NO_INTERRUPT
2025-08-13 · Robin Murphy <robin.murphy@arm.com> -
STALE316d
[PATCH 16/19] perf: Introduce positive capability for sampling
2025-08-13 · Robin Murphy <robin.murphy@arm.com> -
STALE358d
[PATCH 1/1] uapi/termios: remove struct ktermios from uapi headers
2025-07-16 · "H. Peter Anvin" <hpa@zytor.com> -
STALE377d
[PATCH] kmap: fix header include to reflect actual path
2025-06-27 · Aurabindo Pillai <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE188d
[PATCH 02/28] arc: introduce arch_zone_limits_init()
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE188d
[PATCH 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE119d
[PATCH 13/20] mm: convert do_brk_flags() to use vma_flags_t
2026-03-12 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org>